Customer Service Phone Unavailable
Incident Report for The Signal Co.
Resolved
This incident has been resolved.
Posted Mar 10, 2020 - 11:44 AEDT
Identified
A supplier to us has advised that they are currently experiencing an inbound call failure, this started at approximately 9.45am
Posted Mar 10, 2020 - 09:45 AEDT
This incident affected: Customer Interaction Platforms (Phone System(s)).